Home » CMS » Minimum PHP Version update

Minimum PHP Version update

WordPress 5.2 is targeted for release at the end of this month, and with it comes an update to the minimum required version of PHP. WordPress will now require a minimum of PHP 5.6.20.

Beginning in WordPress 5.1, users running PHP versions below 5.6 have had a notification in their dashboard that includes information to help them update PHP. Since then, the WordPress stats have shown an increase in users on more recent versions of PHP.


Screenshot of the "PHP Update Required" widget from the WordPress dashboard. Contains information about detecting an insecure version of PHP, how it affects your site, and a link for information on upgrading.
The dashboard widget users see if running an outdated version of PHP

Why You Should Update PHP

If your site is running on an unsupported version of PHP, the WordPress updater will not offer WordPress 5.2 to your site. If you attempt to update WordPress manually, that update will fail. To continue using the latest features of WordPress you must update to a newer version of PHP.

When updating to a new version of PHP, WordPress encourages updating to its recommended version, PHP 7.3. The PHP internals team has done a great job making its most recent version the fastest version of PHP yet. This means that updating will improve the speed of your site, both for you and your visitors.

This performance increase also means fewer servers are needed to host websites. Updating PHP isn’t just good for your site, it also means less energy is needed for the 1-in-3 sites that use WordPress, so it’s good for the planet.

How to Update PHP

If you need help updating to a new version of PHP, detailed documentation is available. This includes sample communication to send to your host for them to assist you. Many hosting companies have published information on how to update PHP that is specific for them.

5.6 now, but soon 7+

This is the first increase in PHP required version for WordPress since 2010, but may not be the only increase in 2019. The WordPress core team will monitor the adoption of the most recent versions of PHP with an eye towards making PHP 7+ the minimum version towards the end of the year.

Update PHP today, so you can update WordPress tomorrow!

Feed Source: WordPress News
Article Source: Minimum PHP Version update

About Admin

Leave a Reply

Powered by WP Robot