Home » Cloud » Announcing Go 1.8 on App Engine Standard Environment

Announcing Go 1.8 on App Engine Standard Environment


By Vivek Sekhar, Product Manager


We’re happy to announce that Go 1.8 for the Google App Engine standard environment is now generally available and is covered by the App Engine Service Level Agreement (SLA). As of today, Go 1.8 will also be the default for newly-deployed apps that specify “api_version:go1″ in their “app.yaml” files. Existing deployments will not be modified.

Go 1.8 brings a number of library, runtime, performance and security improvements (see the the Go 1.7 Release Notes and the Go 1.8 Release Notes for details). We encourage you to test and re-deploy your apps to make use of them.

Note that the old x/net/context package was moved to the standard library as the “context” package starting in Go 1.7. You can automatically update your imports via “go tool fix -r context” if you have Go 1.8 installed.

If you need to continue deploying apps using the old Go 1.6 runtime, you can update your “app.yaml” file to specify “api_version:go1.6″.

Feed Source: Google Cloud Platform Blog
Article Source: Announcing Go 1.8 on App Engine Standard Environment

About Admin

Powered by WP Robot